Skip to main content

Supported Platforms

Omnibus Firezone currently supports the following platforms:

OSArchitecturesStatusNotes
AmazonLinux 2amd64 arm64Fully-supportedSee AmazonLinux 2 Notes
CentOS 7amd64Fully-supportedSee CentOS 7 Notes
CentOS 8amd64 arm64Fully-supportedSee CentOS 8 Notes
CentOS Stream 9amd64 arm64Fully-supportedWorks as-is
Red Hat Enterprise Linux 7amd64Fully-supportedSee RHEL 7 Notes
Red Hat Enterprise Linux 8amd64 arm64Fully-supportedSee RHEL 8 Notes
Red Hat Enterprise Linux 9amd64 arm64Fully-supportedSee RHEL 9 Notes
Debian 10amd64 arm64Fully-supportedSee Debian 10 Notes
Debian 11amd64 arm64Fully-supportedWorks as-is
Fedora 33amd64 arm64Fully-supportedSee Fedora Notes
Fedora 34amd64 arm64Fully-supportedSee Fedora Notes
Fedora 35amd64 arm64Fully-supportedSee Fedora Notes
Ubuntu 18.04amd64 arm64Fully-supportedSee Ubuntu 18.04 Notes
Ubuntu 20.04amd64 arm64Fully-supportedWorks as-is
Ubuntu 22.04amd64 arm64Fully-supportedWorks as-is
openSUSE Leap 15.3amd64Fully-supportedSee openSUSE Notes

If your distro isn't listed here please try using a package for the closest distro first. For example, since Raspberry Pi OS is based on Debian, try using the Debian Firezone package.

If that doesn't work, please open an issue and let us know. New distros are being supported on a regular basis and there's a good chance yours will be added soon.

Note that we only support RPM and DEB based packaging systems. Others, like Arch Linux are currently being investigated in this issue.

AmazonLinux 2 Notes

Kernel upgrade required:

sudo amazon-linux-extras install -y kernel-5.10

CentOS 7 Notes

Kernel upgrade to 5.6+ required. To upgrade to the latest mainline kernel and select it as the default boot kernel:

sudo rpm --import https://www.elrepo.org/RPM-GPG-KEY-elrepo.org
sudo yum install -y https://www.elrepo.org/elrepo-release-7.el7.elrepo.noarch.rpm
sudo yum install -y elrepo-release
sudo yum --enablerepo=elrepo-kernel install -y kernel-ml
sudo grub2-set-default 0
sudo grub2-mkconfig -o /boot/grub2/grub.cfg
sudo reboot

CentOS 8 Notes

The WireGuard kernel module needs to be installed:

yum install elrepo-release epel-release
yum install kmod-wireguard

RHEL 7 Notes

Red Hat Enterprise Linux is binary compatible with CentOS, so the Firezone package for CentOS 7 should work just fine for RHEL 7. You'll still need to upgrade your kernel to 5.6+ however. To do so, follow the steps for CentOS 7 Notes above.

RHEL 8 Notes

Red Hat Enterprise Linux is binary compatible with CentOS, so the Firezone package for CentOS 8 should work just fine for RHEL 8. You'll still need to install the WireGuard kernel module, however. See CentOS 8 Notes above.

RHEL 9 Notes

Use the package for CentOS 9.

Fedora Notes

On fresh Fedora installations you'll probably need to install a cron implementation to support the logrotate functionality, otherwise you may receive errors about a missing /etc/cron.hourly directory.

yum install cronie-anacron

Ubuntu 18.04 Notes

Kernel upgrade to 5.4+ required:

sudo apt install linux-image-generic-hwe-18.04

Debian 10 Notes

Kernel upgrade to 5.6+ required. See this guide for an example.

openSUSE Notes

Firezone requires the setcap utility, but some recent openSUSE releases may not have it installed by default. To fix, ensure libcap-progs is installed:

sudo zypper install libcap-progs